Most likely what has occurred is your .alb file was created with WebEasy 4. There were some placeholder images created by one of the Auto Links objects. In WebEasy 4, these refer to images in a file called "ixlauist.dll". For WebEasy 5, this is renamed to "vcomuist.dll", which is what caused the "you need DirectX 8.1" error message.

There are two possible solutions:
1) Just ignore the DirectX error message, it is not critical
2) Delete those missing images and use one of the Auto Links to recreate them